Does not install all updates + other issue with updates.

Apr 3, 2014 at 4:20 PM
Edited Apr 3, 2014 at 4:22 PM
Issue 1:
I ran this on a fresh build of Windows 7 Enterprise and used it to update the PC. It often says no reboot is needed, but will not install the remaining updates without a reboot. (Sometimes I have to remove and re-add the PC to the GUI to get it to install more updates.)

Issue 2:
It will say there are 7 updates to install, but the install report will show 10 updates. Why?

Issue 3:
It will not install needed .Net updates. (KB2858725) I have removed the PC from the GUI, restarted the PC, and re-added the PC. Then I run an Audit and it shows 1 update. I tell it to install and it says it did, but it DID NOT. If I can see it on the PC, then it has been approved in WSUS.

Issue 4:
Not related to updates - How do I hide the VB command prompt on the remote PC? I want to use this for PC's that are off when WSUS pushes updates and I would like to not freak out the user or have them close the box.

Thank you,

C68
Aug 18, 2014 at 10:00 AM
Edited Aug 18, 2014 at 11:15 AM
Issue 3: I have the same problem. It seems to me, it occur if the update is an application. We have several application (msi and exe files) which will be deployed through WSUS. It work normally without problem by using Windows Update GUI.

If I want to use PoshPAIG 2.1.5, it shows me one update after auditing patches. That's for example a MSI file, which updates an already installed MSI file (both are the same application with different version number - the newer MSI file updates the older MSI file). If I run "Install Patch" through PoshPAIG, it show me after some time "Completed". If I look to that computer it shows me still that update/application as missing. I'm able to try again with PoshPAIG with the same result.

Another example for with a different computer shows me four updates after auditing patches. One patch is the same MSI file from above and three patches are hotfixes from Microsoft. If I use "Install Patch" through PoshPAIG it shows me again "Completed" and through a check on that computer I'm able to see that the three hotfixes are installed, but not the MSI file.


Please for help. How to fix that strange problem? It seems to me that something is wrong with PoshPAIG and update script. Some more details: I use PsExec v2.11 and Windows Server 2012


edit: if I run "PsExec.exe \computername cscript.exe c:\update.vbs", then the msi file will be installed without problem. "update.vbs" was created by PoshPAIG during "Install Patches"...
edit2: Ok, "PsExec.exe \computername cscript.exe c:\update.vbs" worked on some computer, but not with all. It seems to me, the problem is update.vbs. There is some problem with that script.

best regards, Andyt
Sep 22, 2014 at 8:06 AM
Hello,

i have the same Problem with my update procedure.
Any solution for?


best regards

Torsten